Início > informática > Zend Framework: mysqlnd cannot connect to MySQL 4.1+ using old authentication

Zend Framework: mysqlnd cannot connect to MySQL 4.1+ using old authentication

Hoje retomei o desenvolvimento em um sistema, fiz uma nova instalação do Zend Studio (ZendServer-CE-php-5.3.0-4.0.6-Windows_x86). Mas ao conectar em um servidor SQL remoto, recebi a seguinte mensagem de erro:

SQLSTATE[HY000] [2000] mysqlnd cannot connect to MySQL 4.1+ using old authentication

Procurando por respostas no Google, vi um blog dizendo que no PHP 5.3, o php_mysql e o php_pdo_mysql usa uma senha com seguran’ca melhorada, mas alguns servidores podem estar usando o formato de senha antigo.

A solução é desabilitar no arquivo “my.cnf”:

the solution is to disable the old_passords in my.cnf

Anúncios
Categorias:informática Tags:, ,
  1. Nenhum comentário ainda.
  1. No trackbacks yet.

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: